site down
Incident Report for AppSumo
Resolved
we have reverted, site is now fully functional.
Posted Mar 17, 2021 - 23:35 UTC
Investigating
we are working to resolve the issue
Posted Mar 17, 2021 - 23:29 UTC
This incident affected: Browse, Login, and Product Detail Page.